<- anleitungen ^ beiträge ^ karten -> ---- ====== Georeferenzierung mit Qgis ====== ===== Einleitung ===== Diese Anleitung bezieht sich auf das [[geschichtskarten:Projekt|Projekt German Maps, Topographische Karte 1:25,000 1936 als Hintergrundlayer]].\\ Zum Einlesen des Referenzlayers OpenStreetMap wird eine Internetverbindung benötigt. ===== Installation ===== QGIS kann so installiert werden: * Für Windows, lade den http://www.qgis.org/de/site/forusers/download.html Installer herunter (181-191 MB) und starte ihn.\\ Die Installation erfolgt dann automatisch. Für andere Plattformen stehen auf dieser Seite ebenso eine Anleitung und Installationspakete zur Verfügung. * Die Georeferenzierung mit Qgis erfordert, dass Gdal installiert ist. http://trac.osgeo.org/gdal/wiki/DownloadingGdalBinaries Downloadquellen ===== Download German-Maps Karten ===== Zum schnelleren Finden der richtigen Karte kann http://www.netzwolf.info/kartografie/openlayers/tkgrid Netzwolfs Blattschnitt der TK25 Karte verwendet werden. * Die ID der Blattschnitt-Karte ist identisch mit der ID der German-Maps Karte.\\ * Der Download der Karte erfolgt unter http://contentdm.lib.byu.edu/cdm/search/collection/GermanyMaps German Maps\\ * Dort im Suchfeld die ID der Karte eingeben: {{:wiki:Qgis-hp8.png|ID im Suchfeld eingeben}}\\ \\ Hinweis: die ID Suche funktioniert immer nur von der Startseite http://contentdm.lib.byu.edu/cdm/search/collection/GermanyMaps German Maps aus!\\ {{:wiki:Qgis-hp9.png|800px|Karte gefunden}}\\ \\ Auf der Seite mit Herunterladen -> groß (>500x500) die Karte downloaden\\ {{:wiki:Qgis-hp10.png|Herunterladen, groß (>500x500)}}\\ Anschließend ist der Rand mit Legende mit einem Grafikprogramm zu entfernen, und die Karte im **PNG Format !** neu zu speichern.\\ ===== Georeferenzierung mit mit dem Freehand Georeferenzer ===== http://mystic.historic.place/videos/Freehand_Georeferenzer_Qgis.mpeg Download Video ===== Georeferenzierung mit Referenzpunkten ===== * Qgis starten, und unter **Web -> Openlayers Plugin -> Openstreetmap** aktivieren wir OpenStreetMap als Referenzlayer. Hinweis: eventuell muß das Openlayers Plugin erst unter Erweiterungen -> Erweiterungen verwalten und installieren aktiviert bzw. installiert werden.\\ {{:wiki:Qgis-hp1.png|OpenStreetMap als Referenzlayer laden}} ** [[File:Qgis-hp2.png|800px|OpenStreetMap Layer geladen]] ** Zur Hilfe beim Auffinden der Kartenecken, die [http://gk.historic.place/tools/tk25.gpx.zip tk25.gpx Blattübersicht] downloaden, entpacken und anschließend unter: *** Vektor -> GPS -> GPS-Werkzeuge in Qgis laden ***; Hinweis: eventuell muß das GPS-Werkzeuge-Plugin erst unter Erweiterungen -> Erweiterungen verwalten und installieren aktiviert bzw. installiert werden. *** [[File:Qgis-hp3.png|800px|GPS-Werkzeuge wählen]] *** [[File:Qgis-hp4.png|800px|Datei Suchen]] *** [[File:Qgis-hp5.png|800px|tk25.gpx auswählen]] *** [[File:Qgis-hp6.png|800px|nur Spuren auswählen]] *** [[File:Qgis-hp7.png|800px|Blattübersicht tk25.gpx geladen]] ** Laden der zu georeferenzierenden Karte mit *** Raster -> Georeferenzierung -> Georeferenzierung ***; Hinweis: eventuell muß das GDAL-Georeferenzierungs-Plugin erst unter Erweiterungen -> Erweiterungen verwalten und installieren aktiviert bzw. installiert werden. *** [[File:Qgis-hp11.png|800px|Georeferenzierungs Fenster öffnen]] ** Im Gereferenzierungsfenster Datei -> Raster öffnen anklicken und Karte laden: *** [[File:Qgis-hp12.png|800px|Im Georeferenzierungsfenster Karte laden]] ** Als Projektion WGS 84 / Pseudo Mercator EPSG:3857 wählen *** [[File:Qgis-hp13.png|800px|Pseudo Mercator EPSG:3857 wählen]] *** [[File:Qgis-hp14.png|800px|Karte geladen]] ** Mit dem Mausrad, oder Handauswahl bzw. + oder - zur linken oberen Ecke zoomen *** [[File:Qgis-hp15.png|800px|Zur linken oberen Ecke zoomen]] ** Ins Qgis Hauptfenster wechseln, und ebenfalls in die linke obere Ecke des Blattschnittes der Karte zoomen *** [[File:Qgis-hp16.png|800px|Obere linke Blattschnittecke im Referenzlayer]] ** Ins Georeferenzierungsfenster wechseln *** Bearbeiten -> Punkt hinzufügen auswählen, und eine markannte Stelle im Georeferenzierungsfenster anklicken, *** die auch im Referenzlayer des Qgis-Hauptfensters erkennbar ist. *** Im Kartenkoordinaten eingeben Fenster -> Aus Kartenanzeige anklicken. *** [[File:Qgis-hp17.png|800px|Aus Kartenanzeige auswählen]] *** Es wird automatisch ins Qgis Hauptfenster gewechselt, wo die markannte Stelle wie im Georeferenzierungsfenster angeklickt wird. *** Das Kartenkoordinaten eingeben Fenster erscheint wieder mit den x/y Koordinaten. *** Dies bestätigen wir mit OK *** [[File:Qgis-hp18.png|800px|Im Kartenkoordinaten eingeben Fenster mit OK bestätigen]] *** Anschließend haben wir den Passpunkt im Georeferenzierungsfenster *** [[File:Qgis-hp19.png|800px|Der Passpunkt im Georeferenzierungsfenster]] *** und im Referenzlayer sichtbar. *** [[File:Qgis-hp20.png|800px|Der Passpunkt im Referenzlayer]] ** Das Setzen der Passpunkte wiederholen wir an den restlichen drei Ecken der Karte ** Die vier Passpunkte im Georeferenzierungslayer *** [[File:Qgis-hp21.png|800px|Die vier Passpunkte im Georeferenzierungslayer]] ** und im Referenzlayer *** [[File:Qgis-hp22.png|800px|Die vier Passpunkte im Referenzlayer]] ** Im Georeferenzierungsfenster machen wir folgende Einstellungen unter *** Einstellungen -> Transformationseinstellungen *** Als Ausgaberaster wird der Speicherort der Geotiff Datei gewählt. *** Anschließend mit OK bestätigen. *** (Hinweis: Eine sehr gute Angleichung erhält man mit der Einstellung Transformationstyp: '''Thin Plate Spline''' bei der Verwendung von etwa 12 Passpunkten. Ich nehme immer 4 in den Ecken, 4 an den Kanten und 4 in der Mitte verteilt. Das erfordert etwas mehr Zeit, lohnt sich aber) *** [[File:Qgis-hp23.png|800px|Transformationseinstellungen]] ** Zur Sicherheit speichern wir nun die Passpunkte im Georeferenzierungsfenster unter *** Datei -> Passpunkte speichern als ** Im Anschluß kann die Georeferenzierung gestartet werden mit *** Datei -> Georeferenzierung starten *** Die Geotiff-Datei wird automatisch ins Hauptfenster von Qgis geladen *** [[File:Qgis-hp24.png|800px|Die Geotiff-Datei im Hauptfenster]] ** Dort wird zur Überprüfung der Geotiff-Layer mit der rechten Maustaste angeklickt, und unter Eigenschaften die Transparenz auf 50% gestellt *** [[File:Qgis-hp25.png|800px|Die Geotiff-Datei Einstellungen]] *** [[File:Qgis-hp26.png|800px|Die Geotiff-Datei Transparent machen]] ** Reinzoomen und passt :-) *** [[File:Qgis-hp27.png|800px|Die Geotiff-Datei und Referenzkarte passen]] [[Category:DE:Historic.Place|Anleitungen]] [[https://wiki.openstreetmap.org/wiki/DE:Historical_Objects/Anleitungen|Georeferenzierung mit Qgis]]\\ [[https://youtu.be/0yMzYCNTl4U|Freehand Georeferenzer Qgis]]